Deprecated: imwpcache\f884414bce24ee67f\f73723ec7b1919fa5::__construct(): Implicitly marking parameter $YECBGYFECGEAFWHA as nullable is deprecated, the explicit nullable type must be used instead in /www/wwwroot/www.chuangxiangniao.com/wp-content/plugins/imwpcache-dist/build/f884414bce24ee67ff73723ec7b1919fa5.php on line 2

Deprecated: imwpcache\f884414bce24ee67f\f73723ec7b1919fa5::__construct(): Implicitly marking parameter $BBWFDDBHHYHDXXAB as nullable is deprecated, the explicit nullable type must be used instead in /www/wwwroot/www.chuangxiangniao.com/wp-content/plugins/imwpcache-dist/build/f884414bce24ee67ff73723ec7b1919fa5.php on line 2
linux无法被外部主机访问_创想鸟

linux无法被外部主机访问

linux无法被外部主机访问

原因:

防火墙问题

解决方法:

方法一:关闭防火墙

[root@localhost ~]# service iptables stop         #关闭防火墙[root@localhost ~]# service iptables start         #开启防火墙[root@localhost ~]# service iptables status         #查看防火墙状态

cenOS7或者Red Hat7操作防火墙的命令改变了,命令如下:

[root@localhost ~]# systemctl stop firewalld.service             #关闭防火墙[root@localhost ~]# systemctl start firewalld.service             #开启防火墙[root@localhost ~]# systemctl status firewalld.service          #查看防火墙状态

方法二:开放指定的端口

[root@localhost ~]# vim /etc/sysconfig/iptables:INPUT ACCEPT [0:0]:FORWARD ACCEPT [0:0]:OUTPUT ACCEPT [0:0] -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT -A INPUT -p icmp -j ACCEPT -A INPUT -i lo -j ACCEPT -A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT  -A INPUT -m state --state NEW -m tcp -p tcp --dport 8080 -j ACCEPT  -A INPUT -j REJECT --reject-with icmp-host-prohibited -A FORWARD -j REJECT --reject-with icmp-host-prohibited

备注: 找到 -A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT   这一行,在这一行后添加-A INPUT -m state --state NEW -m tcp -p tcp --dport 8080 -j ACCEPT ,即可开放8080端口

[root@localhost ~]# service iptables restart      #重启防火墙才能生效

cenOS7或者Red Hat7开放端口方法如下:

绘蛙AI视频 绘蛙AI视频

绘蛙推出的AI模特视频生成工具

绘蛙AI视频 127 查看详情 绘蛙AI视频

[root@localhost ~]# firewall-cmd --zone=public --add-port=8080/tcp --permanentsuccess[root@localhost ~# firewall-cmd --reload          #开放端口只需需要重启防火墙才能生效success

备注:开放端口命令解释

-zone    作用域

-add-port=8080/tcp    添加端口,格式为:端口/通信协议

--permanent    永久生效

推荐教程:linux教程

以上就是linux无法外部主机访问的详细内容,更多请关注创想鸟其它相关文章!

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。
如发现本站有涉嫌抄袭侵权/违法违规的内容, 请发送邮件至 chuangxiangniao@163.com 举报,一经查实,本站将立刻删除。
发布者:程序猿,转转请注明出处:https://www.chuangxiangniao.com/p/762910.html

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
OPPO K15 音量过低 OPPO K15 音效增强技巧
上一篇 2025年11月26日 01:47:09
win10怎么找到并打开控制面板_win10控制面板快速访问技巧
下一篇 2025年11月26日 01:47:10

相关推荐

发表回复

登录后才能评论
关注微信