Centos httpd启动失败的解决方法

Centos httpd启动失败的解决方法

centos httpd启动失败的解决方法

1、首先正常启动httpd服务,看出现什么错误。

service httpd start

1.png

2、如果出现“address already in use”则我们需要修改我们的端口,上图中是无法绑定88端口,也需要再次修改端口号,执行:

vi /etc/httpd/conf/httpd.conf

微信截图_20200317132046.png

执行(推荐学习:navicat教程)

semanage port -l|grep http命令

微信截图_20200317132141.png

Uniform Server Uniform Server

Uniform Server是一个免费的轻量级WAMP服务器解决方案,适用于Windows。采用模块化设计方法构建,包括最新版本的Apache、MySQL或MariaDB、PHP(支持版本切换)、phpMyAdmin或Adminer。无需安装!无需注册表垃圾!只需解压并启动!——-注意:Uniform Server的最新版本需要**64位版本**的Windows。——-

Uniform Server 7 查看详情 Uniform Server

3、图中出现的端口号才是可以绑定的端口号,也就是说42行处的端口号可以改为红圈内端口号,80冲突可以换81,当然我们也可以增加端口号,现在执行命令

semanage port -a -t http_port_t -p tcp 888 #增加这个888非标准端口即可

执行之后我们就可以在42行改为888这个端口了。

4、最后,再次启动httpd服务,启动成功!

service httpd start

微信截图_20200317132252.png

本篇文章来自PHP中文网,CentOS使用教程栏目,更多相关教程请关注本栏目!

以上就是Centos httpd启动失败的解决方法的详细内容,更多请关注创想鸟其它相关文章!

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。
如发现本站有涉嫌抄袭侵权/违法违规的内容, 请发送邮件至 chuangxiangniao@163.com 举报,一经查实,本站将立刻删除。
发布者:程序猿,转转请注明出处:https://www.chuangxiangniao.com/p/794568.html

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
java数组怎么测长度
上一篇 2025年11月26日 15:30:18
.NET 程序读取当前目录避坑指南
下一篇 2025年11月26日 15:30:18

相关推荐

发表回复

登录后才能评论
关注微信