开启Oracle数据库闪回功能

–关闭数据库,需要将数据库打开到mount状态才能开启闪回功能: SQLgt; shutdown immediate Database closed. Database dismoun

–关闭数据库,需要将数据库打开到mount状态才能开启闪回功能:
 
sql> shutdown immediate
 
database closed.
 
database dismounted.
 
oracle instance shut down.
 
sql> show user
 
user is “sys”
 
sql> exit
 
disconnected from oracle database 10g enterprise edition release 10.2.0.1.0 – production
 
with the partitioning, olap and data mining options
 
[lubinsu@localhost oracle]$ sqlplus sys/lubinsu as sysdba
 
sql*plus: release 10.2.0.1.0 – production on sat mar 23 20:14:38 2013
 
copyright (c) 1982, 2005, oracle.  all rights reserved.
 
connected to an idle instance.
 
sql> show parameter database
 
ora-01034: oracle not available
 
sql> startup nomout
 
sp2-0714: invalid combination of startup options
 
sql> startup nomount
 
oracle instance started.
 
total system global area  285212672 bytes
 
fixed size                  1218968 bytes
 
variable size              88082024 bytes
 
database buffers          188743680 bytes
 
redo buffers                7168000 bytes
 
sql> alter database flashback on
 
 2  ;
 
alter database flashback on
 
*
 
error at line 1:
 
ora-01507: database not mounted
 
sql> alter database mount
 
 2  ;
 
database altered.
 
sql> alter database flashback on
 
 2  ;
 
alter database flashback on
 
*
 
error at line 1:
 
ora-38706: cannot turn on flashback database logging.
 
ora-38707: media recovery is not enabled.
 
–需要开启归档才能使用闪回功能
 
sql> alter database archivelog on
 
 2  ;
 
alter database archivelog on
 
                        *
 
error at line 1:
 
ora-00933: sql command not properly ended
 
sql> alter database archivelog;
 
database altered.
 
sql> alter database flashback on;
 
database altered.
 
 
 
 
 
sql> alter database open;
 
database altered.
 
–查看能够闪回的最早的scn号
 
–如果返回记录为空,,说明没有打开闪回功能
 
sql> select oldest_flashback_scn from v$flashback_database_log;
 
oldest_flashback_scn
 
——————–
 
        1.3161e+13
 
sql> select flashback from v$database;
 
select flashback from v$database
 
      *
 
error at line 1:
 
ora-00904: “flashback”: invalid identifier
 
–也可以这么查看是否已经打开闪回功能:
 
sql> select flashback_on from v$database;
 
flashback_on
 
——————
 
yes

启科网络PHP商城系统 启科网络PHP商城系统

启科网络商城系统由启科网络技术开发团队完全自主开发,使用国内最流行高效的PHP程序语言,并用小巧的MySql作为数据库服务器,并且使用Smarty引擎来分离网站程序与前端设计代码,让建立的网站可以自由制作个性化的页面。 系统使用标签作为数据调用格式,网站前台开发人员只要简单学习系统标签功能和使用方法,将标签设置在制作的HTML模板中进行对网站数据、内容、信息等的调用,即可建设出美观、个性的网站。

启科网络PHP商城系统 0 查看详情 启科网络PHP商城系统

linux

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。
如发现本站有涉嫌抄袭侵权/违法违规的内容, 请发送邮件至 chuangxiangniao@163.com 举报,一经查实,本站将立刻删除。
发布者:程序猿,转转请注明出处:https://www.chuangxiangniao.com/p/1084245.html

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
composer如何使用vcs类型的私有仓库
上一篇 2025年12月2日 23:06:35
Excel 2016怎么给单元格填充图案-Excel 2016给单元格填充图案的方法
下一篇 2025年12月2日 23:07:04

相关推荐

发表回复

登录后才能评论
关注微信